Home Blog

Archive for December, 2015

Windows 10 compatibility – UPDATE

Wednesday, December 16th, 2015

Both Identity Cloaker and Identity Cloaker Portable now work with Windows 10 normally, including its built-in OpenVPN functionality. The only exception is still the new EDGE web browser – it cannot be cloaked when using the standard Identity Cloaker application, the Portable version, however, does cloak it.

The EDGE problem is being worked on but requires a significant change in the code of the Identity Cloaker application. All other web browsers work with Identity Cloaker without any reported issues.

 

Contact | Helpdesk | Privacy Policy | Terms Of Service
Secured by RapidSSL  Join the Blue Ribbon Online Free Speech Campaign