Home Blog

Archive for March, 2011

Firefox 4 compatibility

Friday, March 25th, 2011

The current version of Identity Cloaker 1 is currently not working properly with Firefox 4 due to significant changes in the Firefox 4 code. The programmer knows about this problem already and is working on a new, Firefox 4 compatible, addon.

We expect it to be available sometime during this weekend. An email will be sent to all customers once it is available and this blog post will also be updated.

Thank you for your understanding!

London datacenter problem causing slow connection

Tuesday, March 22nd, 2011

Yesterday we were notified of a problem with our London datacenter (one of the largest DC in the UK). While the connection was stable, it was quite slow too. We asked the datacenter support for an explanation and were told there were problems with their fibre optic backbone provider. A few hours later the problem was resolved.

Unfortunately, it seems the problem is back today, we will share more information with you as we receive it. In the meanwhile, please connect via our UK7 server which is hosted in our Newcastle datacenter.

We apologize for the inconvenience this may have caused you. Please rest assured we are working on resolving the issue as soon as possible.

Contact | Helpdesk | Privacy Policy | Terms Of Service
Secured by RapidSSL  Join the Blue Ribbon Online Free Speech Campaign